F1Audio

MH-871 Cutter moves but blade doesnt lower

Recommended Posts

Cutter moves but blade doesnt lower to cut vinyl! Only used t like to times. Worked awesome but this is happening? Only 2 months old if that! Just moved into new shop and started using it today and now its not working, please help

Share this post


Link to post
Share on other sites

remove the cover of the carriage.There should be a rod type thing that goes into the blade holder that lowers it. I have seen it slip out. Just stick it back in.

Share this post


Link to post
Share on other sites

There's a type of cooper coil cylinder, where is the rod? And i think it may be connected, bc when you push down on the holder the inside cylinder moves. I dont think its getting signal or power to control the arm from the cutter its self.... I dunno

Share this post


Link to post
Share on other sites

I have the same issue what is the solution .but mine is go up and down but not putting enough pressure please help me with this 

Share this post


Link to post
Share on other sites

What do you have the pressure set to?

Do you have the blade set correctly?

Is the cutting strip still good?

Is the blade holder properly seating and secure?

Share this post


Link to post
Share on other sites
10 hours ago, darcshadow said:

What do you have the pressure set to?

Do you have the blade set correctly?

Is the cutting strip still good?

Is the blade holder properly seating and secure?

try every setting even all the way up

 

Share this post


Link to post
Share on other sites

i have the same same 871 before thats why i bought another one but this one not working as it should

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now