Sign in to follow this  

Copam CP 2500 USB and CORRECT SignGo 1.20 Driver Settings

Recommended Posts

I'm just posting this in the Copam section in case it helps someone in the future getting their CP-2500 cutter to work via USB connection in SignGo 1.20 FD (or just Light or Pro version without dongle) in Windows 7 64bit (It will work on 32 bit too). 


Long story short, it turns out the default settings for the driver are incorrect. So when you install the Copam CP-2500 driver during initial installation (or even Generic HPGL drivers) there needs to be a modification made to the END: form input field under the Commands tab to get it to work. By default it comes with PU;IN; (Pen Up and Initialize) commands in that field. The correct settings for the cutter to cut via USB connection are PU;!PG;; (notice the exclaimation mark and TWO semi-colons). 


After that, it will work. For the record, here is the thread I worked through with SignGo's author Kevin Wallace to solve this problem.


Note: in order to get the CUT icon in the SignGo GUI (graphical user interface) to not be greyed out and be enabled and to subsequently be able to adjust your cutter settings, you need to draw something on the canvas first so use a square or star and put it anywhere on the canvas. Then you will be able to select the Cut icon and from there it's pretty evident with what I'm talking about adjusting commands.


Here are ALL the Commands for the Copam to work via USB connection (notice the bold End: area)


Initialize: IN;
Start plot: PA;
Start cut: PA;
Reset: IN;
Move: PU#,#;
Line: PD#,#;
Bezier curve: (BLANK FIELD)
End: PU;!PG;;
Set origin: PU;PA#,#;PG0;
Set depth: (BLANK FIELD)
Set speed: VS#;
Select pen: SP#;
Get plotting area: OH;PU;
Get Head Position: OA;
UNCHECKED BOX for Uses Multiple Points In Line Command and therefore its Start line, Continue line and End of line fields are greyed out.

However, it does also work with the BOX CHECKED for Multiple Points In Line Command too.


Also, when you install your COM# (# being a number assigned by the computer), make sure your port settings in the Control Panel  > Device Manager > Ports on Windows 7 are set to 9600 Bits/sec, 8 Data bits, Parity None, Stop bits 1, and Flow control is set to Hardware.


In SignGo's Communication Tab: Make sure things are set to 9600 Bits/sec, 8 Data bits, Parity None, Stop bits 1, Flow control DTR/DSR is checked and RTS/CTS is checked. XON/OFF is NOT checked. Timeout is 60 seconds.


This should help get things working.







Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this