Recommended Posts

I just want to air this out.  I have used VM software for a while. I started with a LTR and paid extra for the DSR. 

After about 2 years of use, I can tell you what others that used this software confirmed. 

1 - Software support is terrible. Its all outsourced and they ONLY quote FYI pages and answering questions like robots.  There is no personalization. There is no answer to specific questions. Just copy and paste book answer. Good luck asking random question. You will jsut get the same copy and paste book answer.   Straight up terrible.  None of their copy and paste answer work on the problems anyway.  If you tell them it didnt work - they will just stop replying completely ignore you!!!!! They will not try to troubleshoot an issue at all. They dont even ask you what system you have to see if its compatible. Just random copy and paste book answer.  There is no personality in their service!!! Typical outsource issue!  

2 - Software crashes all the time. Software is made for 32 bit version of windows while many of us have a 64 bit - making things very unstable.  Many times after software crashes, file is unrecoverable.  If you didnt make a backup of the file - you are crap out of luck.  I have a win 10, with Intel 7 processor and 16gb of ram which should be plenty to run it.  I even reinstalled the windows to a fresh copy and same thing happens.

3 - Spool queue always leaves the jobs hanging when you try to send a new job. You have to delete each job you sent separately. It does not work like most printers out there where you send the job and it clears up.  This software does not do that. Each time I send a job -  

Yes, there are some good features in the software but the fact that software crashes all the time and each job has to be deleted manually before next one is sent to the spool queue is a big NO NO. 

I already switched over to another software but I figure I give new people some feedback.  DONT WASTE YOUR MONEY on this software! 

Share this post


Link to post
Share on other sites

I've never tried to get support, but I've not had any of the problems you are describing while running Win 11, 64- bit.

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...