Creation PCut CR630 not finishing cuts (Static issue?)...

Recommended Posts

Hi everybody,

I have been using a Creation PCut CR630 for quite a while now and, excluding the occasional minor error, I have generally not had any issues with it, until now.

A few days ago I sent a design from Signcut to the cutter and everything started as usual, but about halfway through the cut it stopped cutting the design and instead cut a diagonal line all the way back to the starting point, displaying a 'Waiting' message on the LCD screen. Now it does this nearly everytime I try to cut a design, no matter how simple or small the design. After a while I got sick of wasting vinyl, so I removed the blade from the holder and began to carry out a few tests.

I'm pretty sure it is an issue with static electricity, since I only get this problem when using white vinyl. When I run a test cut with either no vinyl or non-white vinyl, the cut completes just fine.

I have tried running a ground cable from the bottom of the cutter to the stand, but this hasn't resolved the problem. The 'feet' on the bottom of the stand have a plastic base, and the floor is wooden. Could this be the problem?

I've tried installing the latest FTDI driver, to no avail.

I am using the following settings, in both Device Manager (Windows 7 64-bit) and Signcut Productivity Pro:

Bits per second: 9600

Data bits: 8

Parity: None

Stop bits: 1

Flow control: Hardware

I am using the following advanced Port Settings (In Device Manager):

Com Port Number: COM4

USB Transfer Sizes

Receive: 4096 bytes

Transmit: 4096 bytes

Latency Timer: 16 msec


Minimum Read Timeout: 0 msec

Minimum Write Timeout: 0 msec

Serial Enumerator: Checked

Serial Printer: Checked

Cancel If Power Off: Checked

Event On Surprise Removal: Checked

Set RTS On Close: Checked

Disable Modem Ctrl Alt Startup: Unchecked

I'm going to try wiping the cutter and stand down thoroughly with dryer sheets, as well as placing a dryer sheet inside the vinyl roll itself, and possibly tape some dryer sheets to the rollers and back of the cutter, so that the vinyl comes into contact with the sheets before reaching the blade. If all else fails, I'm going to try using a humidifier.

For the record, as much as I'd love to use a serial connection, my cutter only has a USB port, so I'm stuck with that.

Anybody got any other suggestions as to what might be causing the problem, and how to fix it?

Thanks in advance!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now