Guest redman

Refine mh721-artcut software setings

Recommended Posts

Guest redman

could anyone tell me what settings i need to make so that the artcut prog. will cut. cheers redmanjavascript:void(0);


Share this post

Link to post
Share on other sites


Artcut software only installs in Chinese

If you are using Artcut 2005 there should be 2 CD?s in the case. The blue CD that says Artcut 2005 is the one you should install which should be in English or at least have an option to install in English. At some point in the install it may ask you to insert the second disk which is the disk with the Chinese characters that says Artcut graphic disk. That disk is in Chinese but you only need to insert it briefly so that the install can continue and you normally will not need to use the Chinese disk again unless you reinstall the program.

Problems Cutting

Check to make sure the cables are connected properly

Are you using the correct driver in the cutting software?

Run a test cut

Be sure the pinch rollers are tight enough and placed correctly on the ends of the vinyl and somewhere in between.

Connectivity Problems

Windows XP Installation Instructions:

Artcut and most other vinyl / tint cutting software interfaces with the vinyl cutter directly without using Windows drivers. As such, the settings in Artcut are critical. Make sure you use setup ?Refine? as the plotter using the Refine 721 DMPL driver and use LPT1 for parallel connections. In other software programs such as Flexi the Roland PNC 1000 driver will work.

Please note

It is not necessary to install drivers unless you are using the USB connection. The USB connection emulates a serial port and therefore is the same speed as a serial port, so parallel port is the fastest and easiest connection method to set up. It is recommended that you first set up using the parallel port (otherwise referred to as the printer port or LPT1).

Parallel Port

In most cases the parallel port will work by simply connecting the parallel cable and setting up the Artcut software to plot through the LTP1 port. If you do have problems you can try the following steps.

Verify all cables are connected properly and try rebooting the computer and/or plotter.

Make sure you have a parallel cable not longer than 12? (the shorter the better).

No other devices or switchboxes should be connected or daisy chained to the parallel port.

Try changing your parallel port mode to ECP if it is not already. This is done in your computer setup (BIOS) and is it recommended that only advanced users adjust this setting.

Remove any other devices that are listed in control panel>Faxes and printers. You will not actually see the plotter installed as a device here but since it uses a driver through the cutting software but any other installed parallel drivers could interfere with the plotter.


For Serial simply connect the serial cable to the PC and set the Artcut software to print through COM1, and if that does not work try COM2.


If USB port installation is necessary, you will need to install the USB to serial converter drivers.

The newest version of the drivers is available at

Once the drivers are installed, you will need to go into device manager and change the USB port from COM4 (or default setting) to COM1 or COM2 so that it can be recognized in Artcut 2005.

As mentioned before the USB connection emulates a serial port through a serial to USB converter and therefore is the same speed as a serial port. This is the most difficult connectivity method since it is the only method where it is necessary to install a driver. The driver is for the USB conversion cable and not the plotter itself.

Before connecting the plotter install the driver from the mini driver disk included with the cable. If you have the plotter connected it will try to automatically install a driver which could lock up your computer so leave it disconnected during the driver install.

You will need to install the USB 1.1 serial to converter driver.

Once the driver is installed turn off the computer and plotter and connect the cable.

Start your computer and plotter and the plotter should be ready to use.

Be sure to change the port settings in Artcut.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now