Sign in to follow this  
eriksonx

help garaphtec ce 5000-40 craft robo pro

Recommended Posts

hi everyone, im a super newbie, looking for help so go easy on me, I cant seem to get the drivers installed correctly on my Graphtec craft robo pro CE5000-40.  the machine shows up as usb printing support unspecified. ive already tried updating the drivers, ive uninstalled the drivers , ive went thru serveral tutorials, but the machine when plugged in , shows its a usb print suport

Share this post


Link to post
Share on other sites

Is your machine hooked up via USB or via serial port?

which version of windows are you running on?

what software are you trying to use for cutting?

  • Like 2

Share this post


Link to post
Share on other sites
6 hours ago, eriksonx said:

hi everyone, im a super newbie, looking for help so go easy on me, I cant seem to get the drivers installed correctly on my Graphtec craft robo pro CE5000-40.  the machine shows up as usb printing support unspecified. ive already tried updating the drivers, ive uninstalled the drivers , ive went thru serveral tutorials, but the machine when plugged in , shows its a usb print suport

All of my Graphtecs show up in the printers.  So what is your problem?   They have a real USB connection. 

printer1.JPG

Share this post


Link to post
Share on other sites
9 hours ago, eriksonx said:

hi everyone, im a super newbie, looking for help so go easy on me, I cant seem to get the drivers installed correctly on my Graphtec craft robo pro CE5000-40.  the machine shows up as usb printing support unspecified. ive already tried updating the drivers, ive uninstalled the drivers , ive went thru serveral tutorials, but the machine when plugged in , shows its a usb print suport

 

7 hours ago, haumana said:

Is your machine hooked up via USB or via serial port?

which version of windows are you running on?

what software are you trying to use for cutting?

what Haumana said - what software are you using for cutting your vector graphics

Share this post


Link to post
Share on other sites
9 hours ago, MZ SKEETER said:

All of my Graphtecs show up in the printers.  So what is your problem?   They have a real USB connection. 

printer1.JPG

I meant it shows up as "unspecified" usb printing support

 

Share this post


Link to post
Share on other sites
2 minutes ago, eriksonx said:

I meant it shows up as "unspecified" usb printing support

 

Which  cutting software?    Have you set the cutter up to your software? Have you plugged the cutter into your computer and tried to cut?

Share this post


Link to post
Share on other sites
4 minutes ago, MZ SKEETER said:

Which  cutting software?    Have you set the cutter up to your software? Have you plugged the cutter into your computer and tried to cut?

CorelDraw x7 cutting master 2, yes ive plugged it in and it syncs forever. I also tried using the graphtech studio. im now confused by the whole set up, is the ce5000-40 too old to use with windows 10.?  do I even need the drivers to cut? like I said im a newbie im gonna ask newbie questions

Share this post


Link to post
Share on other sites
6 minutes ago, eriksonx said:

CorelDraw x7 cutting master 2, yes ive plugged it in and it syncs forever. I also tried using the graphtech studio. im now confused by the whole set up, is the ce5000-40 too old to use with windows 10.?  do I even need the drivers to cut? like I said im a newbie im gonna ask newbie questions

Which COMMAND do you have the cutter on?  It has to be on GP-GL for Cutting Master.   It would be fine on Windows 10.   You can even run that cutter on FREE Signblazer,  If on Windows.    If you try Signblazer, COMMAND has to be on HP-GL. 

Share this post


Link to post
Share on other sites
1 minute ago, MZ SKEETER said:

Which COMMAND do you have the cutter on?  It has to be on GP-GL for Cutting Master.   It would be fine on Windows 10.   You can even run that cutter on FREE Signblazer  If on Windows. 

its on GL-GL, is there a way to back my way outta the mess I created and start fresh, ill look at sign blazer, if its a bit easier to work with.

 

Share this post


Link to post
Share on other sites
8 minutes ago, eriksonx said:

thank you MZ SKEETER. appreciate your help.

Your welcome.  I hope you can get things going. 

Share this post


Link to post
Share on other sites

Your CE5000 is not listed,  try one of the lower ones.  Maybe they will work.  Maybe not.  You may have to buy software.    If all you need is cutting software.  And you have Windows, you can get Vinyl Master. 

https://vinylmaster.software/

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, MZ SKEETER said:

Your CE5000 is not listed,  try one of the lower ones.  Maybe they will work.  Maybe not.  You may have to buy software.    If all you need is cutting software.  And you have Windows, you can get Vinyl Master. 

https://vinylmaster.software/

The ce5000’s I had worked with ce3000 drivers

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, eriksonx said:

CorelDraw x7 cutting master 2, yes ive plugged it in and it syncs forever. I also tried using the graphtech studio. im now confused by the whole set up, is the ce5000-40 too old to use with windows 10.?  do I even need the drivers to cut? like I said im a newbie im gonna ask newbie questions

Your first problem is Windows 10. I'm not railing on Windows because I'm 85% Mac user. I run my laser from a Windows 10 machine, with CorelDraw - and that last  update Windows pushed out was a dozey. I thought CD was broken. I don't know how many times I uninstalled and reinstalled the software, and I even uninstalled the stupid update, and it was never the same. I still have a huge latency issue when sending files to 'print' to the laser. Mind you, some files are very small - just simple text. So if you can, use another machine that is either Win7 or earlier.

Definitely give SB a try. It looks a little antiquated and a bit like a kids program, but it's a workhorse and can get the job done.

Keep us posted.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, haumana said:

Your first problem is Windows 10. I'm not railing on Windows because I'm 85% Mac user. I run my laser from a Windows 10 machine, with CorelDraw - and that last  update Windows pushed out was a dozey. I thought CD was broken. I don't know how many times I uninstalled and reinstalled the software, and I even uninstalled the stupid update, and it was never the same. I still have a huge latency issue when sending files to 'print' to the laser. Mind you, some files are very small - just simple text. So if you can, use another machine that is either Win7 or earlier.

Definitely give SB a try. It looks a little antiquated and a bit like a kids program, but it's a workhorse and can get the job done.

Keep us posted.

yes that's exactly when I began having issues, shortly after the last update. then again I seem to take anything computer related like  its a rocket science course, when in fact it was a super simple set up... I got it working after a week of frustration, high blood pressure, and the invention of tons of new cuss words....and now I shall cut away. …..thank you for responding …….y'all are the best!...

  • Like 1

Share this post


Link to post
Share on other sites
On 10/13/2019 at 8:38 PM, MZ SKEETER said:

Your CE5000 is not listed,  try one of the lower ones.  Maybe they will work.  Maybe not.  You may have to buy software.    If all you need is cutting software.  And you have Windows, you can get Vinyl Master. 

https://vinylmaster.software/

I got it working Mz. Skeeter, thank you for your quick response and helpful knowledge. much appreciated.

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this