Recommended Posts

Been using the CoPam 2500 with Vinylmaster for years - no problem til I had to get a new computer with Windows 10...

Can't get the plotter to respond now...It gets to the point of 'Ok' ing the cut, it goes to the progress bar box, but nothing happens...

Then I get the " Not Responding " message & it sends a message to Microsoft & I start all over....

Tried a new FTDI cable, tried the old cable ...got an update from Vinylmaster...nothing seems to work....

Any help is appreciated.....

 

Share this post


Link to post
Share on other sites

I am only on Windows 7 (by choice) but I think you should try and update the FTDI driver. They support all kinds of OS versions including Win 10. You can get the latest drivers from here: https://www.ftdichip.com/FTDrivers.htm

and specifically the Virtual Com Port drivers (VCP) v2.12.28 ( 2017-08-30 ) from https://www.ftdichip.com/Drivers/VCP.htm

Bookmark that site. That's the real deal with always the latest working drivers. Oh, and a tip, look in the comments section in that table and download the executable. It's a text link and very easy to miss.

Absolute worst case is you can probably use Oracle VirtualBox to setup a VM environment for Windows 7 as a guest running in a Windows 10 host configuration. But I haven't actually done this myself, just read about it. I didn't want to go through the hassle of Windows 10 and so I stayed on Windows 7. My stuff just works...

You may need to contact Vinylmaster and get some help from them too (whoops missed that you already tried this in your initial reply - I'm doing too many things at once). It could be they need to update their software too. Who knows.

Share this post


Link to post
Share on other sites

hello I am also trying to get my copam on windows 10 any luck?

Share this post


Link to post
Share on other sites

What about updating to Windows11? https://www.youtube.com/watch?v=6guilHhdPSU

Throw SignBlazer onto your computer, and see if it works.

Share this post


Link to post
Share on other sites

Is this the same Copam that you have been trying to get connected since 2017?  Did you ever get it connected and cutting ever? 

Share this post


Link to post
Share on other sites

That video is not real. There won't be a Windows 11, although there is talk of a Windows 12 but that's only a rumor and not supported by MS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now