Hatim

Ct 630 issue, the blade doesn't move up when working

Recommended Posts

Hello, 

Did Someone faced similar issue ? The blade sometimes don't move up when it should move up , like when trying to cut the words for example ( TEST ) the blade start and finish directly without move up between words . I don't know why and what should i do or replace on this machine 

 

Thank you

Share this post


Link to post
Share on other sites

When starting and stopping does the carriage arm ever lift?

Share this post


Link to post
Share on other sites

Sometimes no , i tried to press on down and up button and sometimes when i press down the blade move down and when i press up do not move up till i move it manually . 

Share this post


Link to post
Share on other sites

just a guess if it moves sometimes could be the solenoid - when turned off how easy can you move it up and down by hand?

Share this post


Link to post
Share on other sites

I recommended turning it off so you did not hurt the circuitry.   still guessing solenoid or wiring - usually if mainboard it would never go up and down.   I would look for a dealer in your area or contact creation in china to see about getting parts

 

Share this post


Link to post
Share on other sites

The problem is there is no dealer in my area , and i don't know what exactly need to replace on it , to buy it online and replace it , I don't know exactly the problem come from which part

Share this post


Link to post
Share on other sites
7 minutes ago, Hatim said:

The problem is there is no dealer in my area , and i don't know what exactly need to replace on it , to buy it online and replace it , I don't know exactly the problem come from which part

How long have you had that cutter? 

Share this post


Link to post
Share on other sites

It work , but sometimes the blade don't move up when cutting process so it cut from start to finish without move the holder up between words or shapes

Share this post


Link to post
Share on other sites
4 minutes ago, Hatim said:

It work , but sometimes the blade don't move up when cutting process so it cut from start to finish without move the holder up between words or shapes

If that is what it is doing, then it doesn't work correctly.  Contact your seller, if you just bought it. 

Share this post


Link to post
Share on other sites

I don't know if the wires are all soldered in place of if they have connectors. If connectors, it could be something as simple as a loose one. Could also be a wire has broken but still makes intermittent contact.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now