JMurray

Pinch Rollers Not Moving

Recommended Posts

Just started to setup my new Titan Desktop Cutter and I can't get the rollers to move. Demos  show that they are hard to move but, they do move, mine don't, am I missing something?

Please help, can't use till I solve this.

Share this post


Link to post
Share on other sites

I don't have a Titan, but do they have set screws holding them against the bar.?   If so loosen it a little and see if they move.  My Graphtec has  a screw to loosen to move...Or try a little  light oil on a clean cloth and wipe that bar a little that they slide on.   

Share this post


Link to post
Share on other sites

There are adjust knobs on the bottom of the pinch rollers, got it to work, finally. I have a Graphtec too and it work a little differently, but i'll get use to it.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Primal Decals said:

Dont touch those adjustment knobs lol... On my titan my arms that slide are a little stiff and takes a little finger muscles.

Sorry, but that was the only way I could get the pinch rollers to move, loosed them, move the rollers and then re-tighten them.

Share this post


Link to post
Share on other sites
7 hours ago, JMurray said:

Sorry, but that was the only way I could get the pinch rollers to move, loosed them, move the rollers and then re-tighten them.

even when you pulled the arms up to lift the pinch rollers off the surface?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now