Recommended Posts

Titan 2 53" - The issues...

1- Sometimes says it cannot find port. I restart pc and then it'll cut.

2- Sometimes it'll stop cutting in the middle of a graphic. Blade stays down on vinyl until I turn cutter power off. Turn power back on and blade raises up.

3- Started cutting words/letters offset from the word/letter beside it. 

4- Blade stopped dropping down to vinyl. Runs through the motions as if it were cutting but blade never drops down.

It started doing this about 4-5 months ago and read that it needed another ground. Put that on and didn't help. Read that something on the motherboard went out. Spent $250 on a new motherboard and it worked fine until now. Doing everything over again. I'm not spending another $250 for another motherboard. I called USCutter tech and they won't talk to me since I didn't purchase it from them originally. Which I think that is B.S.! I've spent a lot of money with them in the last few months. Anybody have any ideas? This cutter pays my bills and is out of commission right now.

Share this post


Link to post
Share on other sites

never heard of an extra ground needed on a titan - must be you read that on another forum??   although we have seen a couple of issues the titans have been pretty reliable so for 2 mainboards to go out is suspicious in itself . . . . do you have it on a surge suppressor?     Since you are doing this to pay the bills I would get a graphtec personally - more money but rock solid like the roland plotters are too.
  was your titan2 53" one of those that only had rollers every 15" ?   never did see then get anymore in after that container load that was built to the wrong specs

Share this post


Link to post
Share on other sites

Ok    but your cutter already have a TRUE USB. connection.   That Tripplite is mostly to help with the cheap Chinese value cutters.   Those are not True USB.  

Try contacting Saga  for tech support.  The Titan is a rebranded Saga.vinyl cutter.    UScutter, doesn't owe you support for the cutter. 

http://www.sagacnc.us/

Share this post


Link to post
Share on other sites

VinylMaster Demo allows cutting or saving? I seem to recall the Demo/Trial version had those disabled, but I could be wrong.

SignBlazer is an alternative software that'll work.  Try using Copam driver for Titan.

Share this post


Link to post
Share on other sites

Use the USB port,Its the best.. I have the titan 2 28" .. And you dont need another ground on that cutter. Sounds like you bought a used unit? Since you had to buy a new motherboard? If it was used, there could of been issues before with it from previous owner if true..or you are the original owner and warranty ran out.

 

For the usb port issue. Sounds like a bad connection. I thought mine was acting up once and it was the cable. What length of cable are you running to your Pc etc?

Share this post


Link to post
Share on other sites

Yes I bought it used. It worked perfect for 6 months before it started messing up. Replaced motherboard and worked perfect for a little while, not long. Now doing the same thing. It's going through the motions of cutting but the blade won't drop down to the vinyl. Same as before the new motherboard. 

Share this post


Link to post
Share on other sites

That sounds like the z-axis chip has gone bad. I believe you can replace just the chip for a buck or two, as long as you are comfortable with soldering.

Share this post


Link to post
Share on other sites

I do not, and actually I was recalling old post that after thinking about it I believe were talking about the MH or SC cutters. Someone else might be able to shed some light of the possibility of replacing the z-axis chip on a titan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now