Sign in to follow this  
Yuval73

Gaphtec Robo Pro Does not cut right anymore

Recommended Posts

Hi.

I have the Graphtec Robo Pro for 4 years already and it worked great until recently.

Machine is not cutting right anymore, especially small or curved lines. sometimes it does not cut the corners all the way, or on straight lines it do a dotted line instead of a clean straight line.

When I cut text with outline it doesn't always do all the outline, or just do the outline in different thickness for different letters, even when in the program it is all the same.

I tried everything and really get frustrated.

I've changed the blade, the blade holder, the push rolls, the cutting strips.

I've played with the force, speed and blade.

I've updated the firmware, re-install the  driver and nothing help, it seem like it get worse and worse.

I'm using the Graphtec ce5000-40 with Corel Draw 6 and Cutting master 2

Any help will be greatly appreciated, hope it's something fixable and i don't need to buy new machine

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this