Sign in to follow this  
Cre8tiveCutter

Sign Blazer Help PLEASE!!

Recommended Posts

Is there anyone out here still using Sign Blazer??? I am in dire need of some assistance! Ive been using Sign Blazer for YEARS, I love it! Ive done hundreds of jobs with it. When I purchased a new cutter ( TC Plotter) from US Cutter they helped me to set it up and its worked beautifully. I have moved my cutter and my computer from one location to another and all of a sudden it wont communicate with my computer...:( I called US Cutter and was told we do not support this software and cant give you any help at all. I begged and pleaded to no avail.  My plotter came with SCAL PRO3, I tried it didnt like it so didnt learn it...:( It will not read ANY of my EPS files. If anyone an help me I would be forever grateful!! US Cutter and I did establish that SCAL will indeed cut with my current set up so the problem is not the cutter, the computer, or any cords... its sign blazer! I sat here this morning and designed 6 different designs to cut this afternoon using sign blazer and cant cut any of them! please help :angry:

Share this post


Link to post
Share on other sites

Go to "Cutter" and then "Setup". Make sure the correct cutter is selected. Go through and select different output devices until one of them works.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the reply, I'm using XP, everything is connected via usb ports, would it make a difference if I plugged the plotter into a different usb port? When us cutter first set it up they had me using CoPamCP2500 plotter in the cutter set up with BLAZER LPT 1. Do I need to turn the plotter off everytime i switch the usb ports? I'm at a loss here

Share this post


Link to post
Share on other sites

No need to turn it off. Start by choosing "USB001", then hit ok and try to cut something. If that doesn't work, then select "USB002" and so on. One of them should work.

 

The TC might be on one of the LPT or COM ports. I'm not 100% sure. Try each one until it works.

Share this post


Link to post
Share on other sites

I have always uninstalled SB then re installed it when I had any issues and that worked.  Give that a try you will not loose your files ...

Share this post


Link to post
Share on other sites

Thanks for the reply, in sign blazer when i click on cutter set up, the drop down menu lists of cutters does not list the TC, I guess thats why US Cutter had me use the CoPamCP2500, and I do not have any USB options, I have tried EVERY output device listed from Blazer LPT1, 2, 3, 4, Blazer COM 1, 2,3 and 4 I even tried the Blazer FILE and the Microsoft Document Imaging Writer....none have worked. I'm at a loss as to why it wont work in the first place, all I did was move it. Any other suggestions besides uninstalling it and reinstalling it? I know you said I wont lose all my files but I'm scared to death that I will LOL!

Share this post


Link to post
Share on other sites

I have the SC model and use Copam2500 for mine. I use USB connection as well and it gives me a new options everytime i plug mine into my laptop. 

Share this post


Link to post
Share on other sites

WOO!!! I finally got it....Uninstalled and Reinstalled looked for a USB port, found USB port 7 clicked on it, changed the baud rate to 38400 ( was 9600) and hit cut...music to my ears! thanks for the help!  THANK YOU!!!!!! You have no idea how much I appreciate the help... :rolleyes:  :rolleyes:  :rolleyes:

  • Like 2

Share this post


Link to post
Share on other sites
I have always uninstalled SB then re installed it when I had any issues and that worked.  Give that a try you will not loose your files ...

Glad you got it that usually worl when there is a issue like that and I told you not to worry about losing your files ...

  • Like 1

Share this post


Link to post
Share on other sites

FYI- If you ever move again, you must use THE EXACT SAME USB PORT that you were using before, not just in the software, but the same HOLE in the computer too, otherwise you will have to start all over....yeah only one way to know that tidbit of information....SMH ( acouple of hours of MY life i'll never get back...

  • Like 1

Share this post


Link to post
Share on other sites

I am having real issues as well, my laptop crashed, so i have installed SB onto my win10 computer, i have USB socket at front of PC, when i check the USB port it says it is working correctly now these are USB 3. ports rather than USB 2. ports.  but nothing seems to work, i have tried to connect it to every setting in SB but it will not cut.

 

I then installed a trial version of signcut, and it said to use the setting LPT1 which i did and it cut (still plugging it in via the USB 3. at front of computer) 

 

So i know my secabo cutter cuts, i did download the secabo drivers - which i know SB will not recognise - however on my laptop, it just cuts using the CreationPcut settings.

 

any tips or trials i can use would be greatly appreciated as i have used SB for so long i just cannot get to grips with changing software

Share this post


Link to post
Share on other sites

Good morning Laura -- try dealing with the problem through your Device Manager settings in Windows.

 

Your computer operating system Port settings are to blame here, apparently.

Unfortunately, I am not familiar with how to access those Port settings within Win10, so I cannot provide step-by-step instructions.

Share this post


Link to post
Share on other sites

S&D thank you, i will give that a try, i had looked in my Device manager settings, but i think i was looking at USB/rather than other connections, on my laptop it is on COMs4 ??

 

Luckily for me, the replacement power lead has worked on the laptop so i am cutting again, but i want to make sure i am not in this situation again, trouble here is nothing supports XP anymore, so if i get new laptop, i will probably be in the same situation

Share this post


Link to post
Share on other sites

I have been running on XP since 2006...It can be used with any software,,,I also have XP back up computers...Can be bought for under $100 free ship on Ebay...XP is very stable...  Why would you need support?  You don't even have to be online. to cut vinyl.but I am every day..  I am writing this on a Toshiba  Laptop A105  with XP.that was new in 2006.( I replaced the screen and the keyboard myself) but it still works great.... I also cut with the same model, dedicated to my vinyl cutter...  I have never had a problem since Microsoft quit the updates.   And I would guess that average this computer has been on for 16 hours a day for the last 10 years.   I think I got my moneys worth.  ;D

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this