Ionic

Please help identifying correct creation model number for JSI-24

Recommended Posts

(as noted by the forum mebers this is not a creation plotter, this is a Copam plotter) I'm still searching for the driver.

 

Hi everyone! We have had a JSI-24 plotter for about 10 years now, the PC that we were using had a fatal HD crash and we lost the cutting software and the drivers.

I have been searching for days for the driver for this plotter. It only has a parallel and serial port on it.

Could some one please help identify the correct creation model number? Or could some one please tell me where I can download the driver?

I found an old flexisign 6.5 software and installed it. The JSI-24 isn't listed. Another option is using a compatible driver from another plotter, does anyone know one that would work?

Again thanks in advance for any help in this matter.

post-88782-0-07363200-1414556484_thumb.j

post-88782-0-41099600-1414556539_thumb.j

Share this post


Link to post
Share on other sites

Wow thank you very much for the quick reply. I will try the Signblazer, how can I use it for longer than the trial period since the company doesn't exist anymore?

 

Does anyone know what type of Copam this plotter is so I can download the driver.

Share this post


Link to post
Share on other sites
Wow thank you very much for the quick reply. I will try the Signblazer, how can I use it for longer than the trial period since the company doesn't exist anymore?

 

Does anyone know what type of Copam this plotter is so I can download the driver.

Signblazer is unlimited trial.  or abandon ware  Trial does not end,,,,  it's FREE

  • Like 1

Share this post


Link to post
Share on other sites
Signblazer is unlimited trial.  or abandon ware  Trial does not end,,,,  it's FREE

Ok that is awesome info, I read a few years back that people were installing and deleting the program becuase of some trail period. Maybe is misread, but thanks for the tip!!

Share this post


Link to post
Share on other sites
Ok that is awesome info, I read a few years back that people were installing and deleting the program becuase of some trail period. Maybe is misread, but thanks for the tip!!

 Your welcome,,,Owner passed away several years ago.  So keep in mind there have not been any updates for years.. So you must use older versions of eps files like version 8.eps 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now