Sign in to follow this  

SCAL 3 Pro not opening on Mac 10.5.8 Leopard

Recommended Posts



I am very new and just set up my machine and am trying to get the program running to no avail. 

I initially tried the cd that came with the cutter and it crashed. 

Then I tried downloading and installing the same version from the site and that crashed as well. 

This happens as soon as I open the program file. 


It states in multiple places on line that its compatible with Mac 10.5 and up -- I'm running 10.5.8



Wondering if there's a patch or something or if someone else has come across this issue. 




Thanks very much

Share this post

Link to post
Share on other sites

I had the same problem. Couldn't even open it long enough to deactivate so I could reinstall. Call support tomorrow. That's what I had to do.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this