stanger

outline issues

Recommended Posts

The good news, I'm getting better. But I still have questions.

 

When I take a regular picture I find on google or whereever or a decal I want to try and make, it put it into Inkscape and convert it to a vector. What is happening is that it's cutting an outline and I'm guessing it's because of the shading on the image.

 

So, for an image, it's making 2 cuts around the outer edge. When I blew up the picture I see this. Is this the problem and if so how do I fix it?

 

 

post-84418-0-79569800-1389905050_thumb.p

Share this post


Link to post
Share on other sites

looks like its creating paths for the solid part of the image as well as the shading on the image.. i don't use inkscape, but what you want to do is merge the paths.

 

also after looking at your cuts, your also going to want to play with the nodes so the outline isn't as jagged because of the pixelation around the edges on the image you are converting.

Share this post


Link to post
Share on other sites

Are you using Edge Detection when you do your trace? If so switch to Brightness cutoff, that should get you the results you're after. I usually change the threashold to .55 but it can vary from image to image. Just play around and see what works best.

Share this post


Link to post
Share on other sites

I don't use Inkscape much either but I do have a copy on my work (other job) computer. If you go to the "view" tab and then hover over the "display mode" then choose "outline" it will remove the colors so you can see what your cutter is going to see. You can remove the lines you don't want or select both and weld them together by selecting "union" from the paths menu or using the keystroke "Ctrl++" I don't know why it's tracing both, could be a setting in the trace image section but I am not familiar enough to help out on that one. 

Share this post


Link to post
Share on other sites

Have your tried to trace it right in sure cuts? Very powerful trace program even if the rest of it is somewhat lacking.

Share this post


Link to post
Share on other sites
What I didn't do was change it to "2" colors for just black and white. After I did that it looked much better. Thanks for the help!!

I'd still suggest trying the Brightness cutoff option. The colors number only matters if you also click the Color Quantization button.

Share this post


Link to post
Share on other sites

Often pictures have to be massaged before hand in a raster based program like photoshop. In this case sharpening the contrast and/or posterizing the im to just 2 colors would eliminate the issue. (as well as some measures in Inkscape... as you found)

  • Like 2

Share this post


Link to post
Share on other sites

thanks everybody for the help, I learned several new things now.

 

When I was looking at it in photoshop, the outline effect was set so that's what was messing me up

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now