Recommended Posts

Good afternoon,


I have a US cutter MH 1351 that I purchased prior to the new year (Oct. or Nov. of 2013).  It was cutting ok (images were bigger than the design) until the Z-axis quit working. I have tried the battery test which worked, we have also purchased the z-chip but it appears that there is the possibility the newer models do not have a z-chip?  If this is the case what do I need to do to get this machine running properly again?


From images on the us cutter web site it appears I have the  MH Series Refine Motherboard MK2.


If the chip is replaceable on this equipment does anyone have an image as to where it may be located?  The chip that I received from US cutter has a part number of RFPZAXCHIP on the bag but on the chip it says EA30.


Thanks in advance for any information.  I really hope to get this running this weekend.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now