teamnrgllc

LaserPoint 2 Blade Doesn't Lift when cutting

Recommended Posts

I'm using a MacBook Pro and the Laserpoint 2 Cutter. The cutter and my computer communicate just fine, where i'm having an issue is when the cutter is cutting the blade doesn't lift up off of the vinyl. For example; when I'm cutting a word it cuts the letters out and cuts from letter to letter as well. Anyone have a solution that can help?

 

Thanks.

Share this post


Link to post
Share on other sites

You'll need to troubleshoot with USCUTTER support, it could be anything from a Z-chip failure to an improperly seated blade holder.

Share this post


Link to post
Share on other sites

I am using a MAC desktop and have noticed when I am cutting a huge list of names, it does the same thing you are experiencing. 

 

In addition to that, very recently, when cutting a project, the machine will cut, but when it finishes the project, it just stops, blade down, and does not return to home/original position as I have it set to do in the settings. I have tried switching to another setting (advance an inch after cutting) to see if the cutter will recognize the setting , but it still just stops in place when it's done with a project.

 

I have to shut the machine off and turn it back on in order for the blade to lift and return to home position.  :wacko:

 

Any idea why it's doing this? Any help would be appreciated.

 

Thanks

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now