Search the Community

Showing results for tags 'need help'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to USCutter
    • Shop Online
    • Customer Support
    • Information For New Equipment Owners
    • Website and Company Feedback
  • Equipment Discussion & Support
    • Vinyl Cutters
    • Heat Presses
    • Competitor Cutter Help
    • Printers
    • Laminators
    • Engravers
  • USCutter Community
    • Community Rules & Announcements
    • Introductions
    • General discussion
    • Show your work
    • Instructional Contributions
    • T-Shirts and/ or Garments
    • Sublimation
    • Business Practices, Sales and Pricing, etc.
    • Mac Users Board
    • Pre-sale questions
    • Off Topic Section
  • Software Discussion & Support
    • VinylMaster CUT, LTR, PRO & DSR
    • Sure Cuts A Lot Pro
    • Signcut
    • SignBlazer
    • Flexi
    • Corel Draw
    • Adobe Illustrator
    • Inkscape
    • Other Software Programs
  • Material Discussion
    • Vinyl
    • Other Materials
  • Feedback Section
    • Criticism and Complaints about USCutter
    • USCutter Equipment Feedback or Suggestions
  • Graphic help and requests
    • General Help
    • Vectorizing
    • Graphic Requests
    • Fonts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. So I was cutting a piece of vinyl and the cut messed up and I had to pull the vinyl out because it was jammed when I went to cut the sheet again it would read it was cutting on the computer but nothing was happening with the cutter I checked the cutter and there was a blank screen I tried resetting it and it would reset display the product name as It does and go blank again I have tried everything I know to do
  2. My USCutter MH721-Mk2 is not completing cuts (i.e. it does not end the cut of a square where it begins the cut, it ends the cut just a small distance away from the starting point of the cut) and also seems like it is slightly tearing the vinyl instead of cutting it. I included a video with the cuts before and after weeding to show you exactly what is happening. My cut settings are in the description of the video and i have a brand new blade in it, also i am cutting Oracal 651 vinyl in case that information can help. Any advice/help would be greatly appreciated!!! Link to video: <iframe width="560" height="315" src="https://www.youtube.com/embed/bH-KKPHy_r0" frameborder="0" allowfullscreen></iframe>