Search the Community

Showing results for tags 'copam 2500'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to USCutter
    • Shop Online
    • Customer Support
    • Information For New Equipment Owners
    • Website and Company Feedback
  • Equipment Discussion & Support
    • Vinyl Cutters
    • Heat Presses
    • Competitor Cutter Help
    • Printers
    • Laminators
    • Engravers
  • USCutter Community
    • Community Rules & Announcements
    • Introductions
    • General discussion
    • Show your work
    • Instructional Contributions
    • T-Shirts and/ or Garments
    • Sublimation
    • Business Practices, Sales and Pricing, etc.
    • Mac Users Board
    • Pre-sale questions
    • Off Topic Section
  • Software Discussion & Support
    • VinylMaster CUT, LTR, PRO & DSR
    • Sure Cuts A Lot Pro
    • Signcut
    • SignBlazer
    • Flexi
    • Corel Draw
    • Adobe Illustrator
    • Inkscape
    • Other Software Programs
  • Material Discussion
    • Vinyl
    • Other Materials
  • Feedback Section
    • Criticism and Complaints about USCutter
    • USCutter Equipment Feedback or Suggestions
  • Graphic help and requests
    • General Help
    • Vectorizing
    • Graphic Requests
    • Fonts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 6 results

  1. Hi, I have been out of commission for quite some time. My copam was josstled quite a bit when moved and now will not show the screen for more than a brief second. The screen will light up when turned on but will only light for a second and then it goes out. I tried all the connections, blew it, cleaned with electronic cleaner, I have checked all the soldering connections and do not see any breaks. Lots I have read lead back to the mother board. Is there anyone that I can send by motherboard to and they can check and see if that is the issue before I go buying a new one?
  2. I am baffled at my copam cutter. It makes a knocking noise when the carriage brings down the blade, which it has never done before. I tried plotting with a pen and it worked great and made no noise. It also won't cut at all uness it is on the lower pressure settings, which makes no sense at all. When I put it on the lowest pressure it will cut, but it skips spots in letters, like it doesn't completely come back to cut where it started (that's plain as mud ) When I up the pressure it starts out great, but after cutting a bit it is only barely marking the vinyl. Checked the cutting strip and it has no cuts. So, not sure what to replace.... the mother board, the carriage, the blade holder???
  3. I am having trouble with uneven cutting using my Copam cutter. I am thinking it may be the cutting strip, as I have never replaced mine. Now for the stupid question....do I have to buy the actual part for the copam 2500 or are there "generic" cutting strips? I just don't want to spend $20 plus shipping and handling in case it is not the problem. I have read also where you can test it by using a pen??? Anyone know how to do that? Also I read where you can use reflective vinyl to replace your cutting strip? Know anything about that??? Thanks in advance!!!!
  4. julie77

    jagged cuts on curves

    Help Please ... Having some issues cutting all of a sudden of curves, they look jagged and speckled not clean at all. Tried the blade offset from .20 to .40 with no change, tried 3 new blades nothing ... Have no clue what else to try . Any suggestions ? Blade offset is at 14 using copam 2500 and SCAL3 Pro
  5. I have a Copam 2500 and it has been working great for 5 years. When I started working on a decal order today, I noticed the control panel buttons were not working. When I press the "Setup" button nothing happens so I can't adjust the speed and force. If I press the "measure" button it doesn't respond so I can't measure my vinyl. Is there anything I can do to fix this problem? Will purchasing a new control panel from USCutter solve the issue or is time to get a new cutter since it is over 5 years old?
  6. we just purchased a copam 2500 w flexistarter 10 software but my CD rom is acting up. is there an actual download for flexi i can use instead of disk.or equivalent software to get me up and running to play w this cutter until my other pc is repaired?any links would be great , Were new to cutting vinyl I did Flexistarter 10.0.4 downloaded but i have windows 7 and its saying incompatible application and sometimes it opens and says key did not match password? Same with production manager 10.0.4...i have signcut and inkscape as well...any suggestions...I have disk but until Dell gets my new cd rom sent im out....unless theres a flexi download avail or another equivalent software program for copam 2500.