blacklabelgraphix

Members
  • Content Count

    44
  • Joined

  • Last visited

Community Reputation

3 Neutral

About blacklabelgraphix

  • Rank
    Advanced Member

Profile Information

  • Gender
    Not Telling
  • Location
    Greensboro, NC

Recent Profile Visitors

684 profile views
  1. blacklabelgraphix

    Any help please!

    If it is bad it didnt last but 2-3 months on a brand new motherboard. You know where the chip is on the motherboard? And where to buy it?
  2. blacklabelgraphix

    Any help please!

    Yes I bought it used. It worked perfect for 6 months before it started messing up. Replaced motherboard and worked perfect for a little while, not long. Now doing the same thing. It's going through the motions of cutting but the blade won't drop down to the vinyl. Same as before the new motherboard.
  3. blacklabelgraphix

    Any help please!

    No I haven't tried other software. I'm currently using Flexistarter 10 to cut from. I also have flexisign 8 and the software that comes with uscutter sc series.
  4. blacklabelgraphix

    Any help please!

    I was using usb to usb for a while. When the stop cutting mid way and not seeing the port started happening i got the keyspan to see if that made a difference. It didnt.
  5. blacklabelgraphix

    Any help please!

    Yes looks like that. I payed $30.
  6. blacklabelgraphix

    Any help please!

    Yes it's plugged into a surge protector. Forgot to mention in original post that I am using a keyspan adapter trying to stop the port issue but that didn't make a difference.
  7. blacklabelgraphix

    Any help please!

    Titan 2 53" - The issues... 1- Sometimes says it cannot find port. I restart pc and then it'll cut. 2- Sometimes it'll stop cutting in the middle of a graphic. Blade stays down on vinyl until I turn cutter power off. Turn power back on and blade raises up. 3- Started cutting words/letters offset from the word/letter beside it. 4- Blade stopped dropping down to vinyl. Runs through the motions as if it were cutting but blade never drops down. It started doing this about 4-5 months ago and read that it needed another ground. Put that on and didn't help. Read that something on the motherboard went out. Spent $250 on a new motherboard and it worked fine until now. Doing everything over again. I'm not spending another $250 for another motherboard. I called USCutter tech and they won't talk to me since I didn't purchase it from them originally. Which I think that is B.S.! I've spent a lot of money with them in the last few months. Anybody have any ideas? This cutter pays my bills and is out of commission right now.
  8. Will a motherboard for a Titan 3 work in a Titan 2?
  9. blacklabelgraphix

    Registration mark aligning - Need help please

    I contour cut in Flexistarter 10.
  10. blacklabelgraphix

    Registration mark aligning - Need help please

    <blockquote class='ipsBlockquote'data-author="Wildgoose" data-cid="419832" data-time="1465311772"><p> Dumb question. When I make my own registration marks in AI (I always make my own) I copy then paste in place or past in front and then just change the color to match the next color layer. Can you not paste in place with Flexi? Seems like a lot of effort for something so simple.</p></blockquote> I'm not having an issue inserting registration marks. I'm having a problem setting the blade holder to all 4 points before telling it to contour cut.
  11. blacklabelgraphix

    Registration mark aligning - Need help please

    I just hooked the cutter back up to the laptop. Everything worked as it should. So now I know it's not the cutter. For some reason somethings not right when it's hooked to the desktop. Desktop - Windows 7 Professional Laptop - Windows 7 Home Premium
  12. blacklabelgraphix

    Registration mark aligning - Need help please

    Thank you for your reply. When I was using the laptop, the blade holder moved as soon as I hit the arrow button on the keyboard and as fast as I hit it. Now when I hit the arrow button on keyboard it might (I mean might) move 5-10 seconds later. And sometimes it doesn't move.
  13. Has anybody had problems with manual alignment of the registration marks with Titan 2 and Flexi? When I hit the arrow buttons on the keyboard there is a long delay before the blade holder actually moves. The arrow buttons on the monitor screen work at exactly the time I hit keyboard button but the blade holder don't move. In an area of 12"x24" it took me 30-45 min to get all 4 registration points entered in. Once I finished aligning the last mark and it started contour cutting perfect. I have made a change since the last time I contoured cut. I was using a laptop, it worked perfect then. Now I transferred everything over to a desktop and this is the first time I've tried to contour cut. It still die cuts vinyl perfect like it always has. No problems with anything else. Any ideas? I contacted USCutter Support about this and won't contact them again...Just because I'm the 2nd owner of this machine they said they won't help me.
  14. blacklabelgraphix

    Transfer Carrier Sheet???

    I thought about poster board but didn't know how good that would work. I'll have to look around to see where I can get some cheap low tack repositionable spray glue.
  15. blacklabelgraphix

    Transfer Carrier Sheet???

    Looks like Walmart don't have bigger sizes. Unless I overlooked it. I'll mostly be using 11x17 transfer papers.